Data settings for Motorola XT1687 G5 Plus running Android 7.0

  • 4 November 2018
  • 2 replies
  • 686 views

I have a Motorola XT1687, aka G5 Plus running Android 7.0. After installing and activating the sim card I could make phone calls but could not get data over LTE. I could tell this because when I left my wifi connection I couldn’t get anything on my internet browser, it just said I wasn’t connected to the internet.

I tried the Mint Mobile recommended settings but they weren’t exactly like what was on my phone so I was guessing a lot. This finally worked for me so I can pass it along to help someone else. So here goes...

Select the settings gear icon then More, Cellular networks, Access point names, then hit the little Circle + symbol to add a new APN named Ultra with the following values. Note that Not Set means just bypass that setting, don’t enter anything.

Name: Ultra
APN: Wholesale
Proxy: Not set
Port: 8080
Username: Not set
Password: Not set
Server: Not set
MMSC: http://wholesale.mmsmvno.com/mms/wapenc
MCC: 310
MNC: 260
Authentication Type: Not set
APN Type: default,supl,mms
APN protocol: IPv4
APN Roaming protocol: IPv4
APN enable/disable: Greyed out, but set to APN enabled
Bearer: Unspecified
MVNO type: None
MVNO value: Greyed out, but shows Not set

It may take several reboots (turn phone off, then on) and 15-30 minutes for this to start working. When you can turn off your wifi in settings and still get to the internet in a web browser that means it’s working.

Also be sure the wifi calling preference is ON, set to wifi preferred. This setting is under More from the first settings panel.

2 replies

I too am finding it very difficult to get the data network to work right. First time ever I may have to set it up manually!
Now that my XT1687 has been updated to Android 8.1 the settings have changed a little, or at least how you get to them.

First select the Gear icon, Network & Internet, Mobile Network, Advanced, then Access Point Names.

There are also two new fields, MMS Proxy and MMS Port. I left both to "not set", which I have no idea if this is right or wrong.

Reply