Question

MMS not working when connected to WiFi

  • 2 November 2018
  • 3 replies
  • 347 views

I have a Galaxy S 8 that when connected to WiFi will not send/receive MMS messages. I have to manually turnoff WiFi to allow send/receive and then reconnect to WiFi. My APN settings are below:


This topic has been closed for comments

3 replies

I had the same issue with the default messaging app on my Samsung Galaxy S7. Replaced the default messaging app with Google Messages and it works fine with SMS/MMS on WiFi.

https://play.google.com/store/apps/details?id=com.google.android.apps.messaging&hl=en&rdid=com.google.android.apps.messaging&pli=1
I tried Google Messages but still MMS did not work while on Wi-Fi. The only solution seemed to be to disable WiFi calling.
I had the same problem even while only on Wifi (does not work while Wifi Calling is 'On'). Called customer service and they said they are aware of the problem and are "working on it". I did some research and found that MANY customers are experiencing the same issue. After some "trial and error" the following worked for me!
Keep the settings as you have it except only change these settings, as follows:

APN TYPE: default,mms,supl,hipri,admin,mobile

APN PROTOCOL: IPv4/IPv6

APN ROAMING: IPv4

TEST by sending a photo to your own cell phone number, spouse or friend. Hope it works for you too!
😉👍🏼 (I hope that Mint Mobile techs also see this solution)