Question

MMS over WIFI

  • 15 May 2018
  • 5 replies
  • 1288 views

The cell signal in my house is practically non-existent and I just got a Moto E4 which uses WiFi Calling. I can send/receive SMS message over WiFi but MMS almost always fails. I read that MMS needs a connection to my cell signal to work even if I'm on WiFi and wondering if that is true? When I am out of my house and have a good signal, MMS works just fine. Is there anything I can do to fix the problem when at home?

APN settings are correct as per Mint Mobile.

Thanks

This topic has been closed for comments

5 replies

Userlevel 4
Badge
Hi there,

In order for MMS to work, there needs to be a data connection and being on WiFi, that can cause an issue. Unfortunately, we cannot guarantee that service will work on any property. Are you using MMS through your device applications or through a third-party app? Have you checked if the data settings are turned on the app as well?
I am having the same issue. APN settings are correct. MMS sends fine over cellular but not over wifi.
Just posted this on a similar thread and thought it may help here too.
I found a workaround/solution. MMS requires mobile data to send and receive where SMS text messages does not. When I had my WIFI enabled I could not send MMS messages. They sent or recieved normally as soon as I disabled my wifi. The workaround after verifying my APN settings were correct and MMS worked while on mobile data was to go to the settings of my android phone and enable developer options. Once enabled an option to keep mobile data on always was there. Once selected my LTE symbol and mobile data stays active even if I enable Wifi. I can now send and receive MMS at all times and still use wifi calling and wifi data automatically when available. To enable developer options I went to settings/about phone and tapped the build number multiple times until prompted if I wanted to enable that feature. Once enabled go to settings/developer options/Keep Mobile Data Turned On and enable it. Fixed.
Just posted this on a similar thread and thought it may help here too.I found a workaround/solution. MMS requires mobile data to send and receive where SMS text messages does not. When I had my WIFI enabled I could not send MMS messages. They sent or recieved normally as soon as I disabled my wifi. The workaround after verifying my APN settings were correct and MMS worked while on mobile data was to go to the settings of my android phone and enable developer options. Once enabled an option to keep mobile data on always was there. Once selected my LTE symbol and mobile data stays active even if I enable Wifi. I can now send and receive MMS at all times and still use wifi calling and wifi data automatically when available. To enable developer options I went to settings/about phone and tapped the build number multiple times until prompted if I wanted to enable that feature. Once enabled go to settings/developer options/Keep Mobile Data Turned On and enable it. Fixed.

I have always had the "Keep Mobile Data on Always" checked and have never gotten MMS when on WiFi.
The "developer option" work-around doesn't work for me either.