Question

MMS problem while on WIFI


Userlevel 2
Hello, I cannot send or receive MMS messages while on WIFI. My phone is a Samsung Galaxy S8. My text message app is Android Messages.

I've noticed when I connect to WIFI the LTE symbol at the top of my phone goes away. When I disconnect from WIFI the LTE symbol immediately appears and my MMS messages download instantly.

I've setup the APN according to MintMobile instructions. Restarted device. Nothing works. The only way I can download MMS messages is to disconnect from WIFI.

Any help would be greatly appreciated.

This topic has been closed for comments

19 replies

found this by googling the issue and mintmobile. i JUST experienced that problem. someone just texted me "it wont let me send you a picture" while i was at home on my wifi, i turned it off and asked him to send again and it worked.

Im assuming it could all be resolved by activating wifi calling on my account but do we really need to?
Userlevel 2
I have WIFI calling activated. It doesn't fix the problem. I've tried a few different APN. Nothing works. It's really frustrating.
i dug around the forums and found https://community.mintmobile.com/your-mint-account-20/what-are-and-why-do-you-need-to-set-up-my-apn-settings-27

setting your APN settings, even if your phone made its own that somewhat work, is the answer. i set my APN settings per the info in that link, tested it again and it worked perfectly. hope it helps!
Userlevel 2
Thanks for your reply. I appreciate it.

Just looked at those APN settings and it's the same ones I've been using. Double checked to make sure it was entered correctly. It doesn't work for me 😞
Userlevel 2
Still experiencing the problem. If anyone has any suggestions I'd appreciate some help.
I had the same issue. Did a restart and everything works fine (been 2-weeks now and no issues).
Userlevel 2
Are you using a Samsung Galaxy S8? A restart didn't work for me. I've tried 4 different recommended APN settings with a restart after each one.
I am. An unlocked Galaxy S8 bought from Best Buy
Userlevel 2
Would you mind sharing your APN settings?
Userlevel 2
Hey Brian,

We're sorry to hear you are having service issues. So we can further assist you, could you please share with us a screenshot of your data settings?

Thanks,
Nicole, Mint Mobile
We have Samsung Note 5 amd are having the exact problem Brian is. Text messages get sent (most of the time,) but pictures dont. 😞
I have a Sprint Note 5 and also can't send and receive mms messages while on wifi, it does work on cellular data thought. I have wifi calling turned on in mint but it doesn't work and it did on Sprint.
Has anyone resolved this issue? I just switched to Mint Mobile and have the exact same problem with a Galaxy S 8. My APN settings are attached.

I have the same issue. Unlocked Galaxy S9, APN settings are correct. MMS works fine over cellular but not on wifi
Same issue on a brand new, factory unlocked Samsung S9.

We've confirmed all APN settings match Mint Mobile's requirements.

Amy suggestions, help, updates are appreciated.
I had the same problem even while only on Wifi (Will not work while Wifi Calling is 'On'). Called customer service and they said they are aware of the problem and are "working on it". I did some research and found that MANY customers are experiencing the same issue. After some "trial and error" the following worked for me!
Keep the settings as you have it except only change these settings, as follows:

APN TYPE: default,mms,supl,hipri,admin,mobile

APN PROTOCOL: IPv4/IPv6

APN ROAMING: IPv4

TEST by sending a photo to your own cell phone number, spouse or friend. Hope it works for you too!
😉👍🏼 (I hope that Mint Mobile techs also see this solution)
Samer issue with my unlocked Samsung Galaxy s8. If I disable Wifi I can send and receive MMS picture messages. No joy with Wifi enabled. Manually created APN settings per instructions and same issue. Finally figured out to disconnect from wifi as a work around. My only issue with Mint mobile.
I found a workaround/solution. MMS requires mobile data to send and receive where SMS text messages does not. When I had my WIFI enabled I could not send MMS messages. They sent or recieved normally as soon as I disabled my wifi. The workaround after verifying my APN settings were correct and MMS worked while on mobile data was to go to the settings of my android phone and enable developer options. Once enabled an option to keep mobile data on always was there. Once selected my LTE symbol and mobile data stays active even if I enable Wifi. I can now send and receive MMS at all times and still use wifi calling and wifi data automatically when available. To enable developer options I went to settings/about phone and tapped the build number multiple times until prompted if I wanted to enable that feature. Once enabled go to settings/developer options/Keep Mobile Data Turned On and enable it. Fixed.
Found the problem!! Turn off Wifi calling. It's not in regular settings. Bring up the phone go the the 3 dots upper right corner, settings, Wifi calling. Top slider. Disabled. BAM.