Question

Wifi calling and messaging - galaxy s9+


I just got Mint and I love it...

Except for the wifi.

I have a Samsung Galaxy S9+ which works great with Mint service away from my house. However, I live on a mountain where I am 2 blocks away from cell service. I need to use wifi at home. It connects for internet perfectly, but calls and texts are random and mostly not happening.

Is there an extra setting i need to use in order to send messages (SMS & MMS) and make calls on wifi?

... wifi - all bands and internet speed 30mbs.

4 replies

Userlevel 4
Badge
Did you sign up for WiFi calling and texting on your account? Can you DM us your phone number?
I have the same problem with my S9. I enabled this in my account but can't use it. It looks like neither of these phones are supported for Wi-Fi calling yet. Any idea when they will be?
Try opening the phone app and tap the three dots on the upper right corner. Choose settings, scroll down and see if 'Wi-Fi Calling' shows on the list. If so, choose that and make your choice in the following menu.
Since installing Android Pie, Wi-Fi calling started to work on my S9. I noticed that S9+ also has Pie now, too. Could this problem be solved on that phone as well?

Reply