Question

Data Not working after setting up APN

  • 18 July 2018
  • 9 replies
  • 7891 views

Hi,
I am having issues with using data on an Honor8, I've setup the APN a few times to make sure I am getting it right.

The only thing that I can think of is that the SIM was activated on an OnePlus One. After inserting the SIM into the 1+1, the data worked for a day but then stopped reading this and any SIM cards (tried t-mobile and freedompop SIMs) so I have ordered a new 1+6.

In the interim while I wait for the new phone to ship I am using it in an Honor8, but the data will not work, do i need to call Mint Mobile to have them add my IMEI?

Any ideas? attaching my APN settings.


9 replies

OK, have an update... in the APN settings there was another T-Mobile APN entry, I clicked on that and it just started working. Ultra/Wholesale entry doesn't work.
I can't get the Ultra APN or the T-Mobile entry to work with any workable data speed, they both work but at 0.15 Mbit and 0.18 Mbit ( 15% and 18% of 1 Mbit). 3G should be 10-20 Mbit, and 4GLTE should be in execess of 50 Mbit ( have got 150Mbit on T-Mobile in some areas).

I am not getting even 20% of 1 Mbit with this service.
Userlevel 1
Had the same issue , all the data setting from Mint website apply , but the MVNO must be set to imsi , this setting is blank as per your post . MVNO stands for virtual network , all third party networks like Mint , Metro etc that piggyback on the major carriers like T Mobile are virtual networks , therefore this setting cannot be blank . I have a ZTE phone , some phones automatically detect the appropriate APN settings but if not , has to be done manually .
Had the same issue , all the data setting from Mint website apply , but the MVNO must be set to imsi , this setting is blank as per your post . MVNO stands for virtual network , all third party networks like Mint , Metro etc that piggyback on the major carriers like T Mobile are virtual networks , therefore this setting cannot be blank . I have a ZTE phone , some phones automatically detect the appropriate APN settings but if not , has to be done manually .

Zinny. THANKS! I spent an hour plus multiple emails with mint and no one said to do anything with the MVNO setting. It instantly fixed my internet data problem. Please share this post for others.

I have a galaxy samsung s7 active
I also have an Honor8x and I'm literally unable to use my data. It takes ~12sec to send a WhatsApp message, google can be acessed (not even entering a search) as often as not, ... you get the picture.
I used to have mint mobile a year ago before I went abroads and used it with my Huawei p9 back then and everything worked.
I've contacted support but they never got back to me, and I tried everything I could find, including adding the imsi setting to the MVNO. Still, nothing. According to IMEI and coverge check, I should be able to receive 4G
Any ideas, anyone? I'm desperate!
Userlevel 1
Thanks for the comments guys, I'm not a tech person but I have an interest in how things work, there are other settings in mvno , I would recommend experimenting with them , bottom line is Mint is a virtual network , so this field cannot be blank , also when it's left blank the settings cannot be saved .
These are the settings that work for me:

Thanks for the info 2min fix on an LG V10, I don't have the mvno option but after updating the APN info without having to turn my phone off and back on. I turned off my wifi & 4G now appears next to the data strength bar. 

Had the same issue , all the data setting from Mint website apply , but the MVNO must be set to imsi , this setting is blank as per your post . MVNO stands for virtual network , all third party networks like Mint , Metro etc that piggyback on the major carriers like T Mobile are virtual networks , therefore this setting cannot be blank . I have a ZTE phone , some phones automatically detect the appropriate APN settings but if not , has to be done manually .

 

 

This solved my issue! wow. What was weird for me was that after I activated without any apn changes (was on Tmobile LTE apn), my data was working fine automatically. Then, I traveled to another state. No data.  I tried turning off 4G, and had data. I tried switching to ultra apn according to the instruction instead of staying on Tmobile, no data at all regardless 4G or not. After adding MVNO to ultra apn, 4G finally works!  Thanks!! They should really add this to the data setting page.

Reply