Question

Data only works off and on

  • 22 December 2019
  • 19 replies
  • 489 views

Userlevel 1

I have an unlocked Galaxy S7 originally bought through AT&T. I've been using Mint for almost a month now. I never have issues with talk and text, but data only works half the time. It will work for a while and then it won't for a while. I have confirmed with multiple customer service representatives that my APN settings are correct. I have restarted the phone, removed and reinserted the SIM and I still have the same issues. I've only had 2 days that I know of where I actually DIDN'T lose data connection at all on those days. I don't know what else to do. When my 3 months are up, I WILL be leaving Mint if this doesn't get resolved. 


19 replies

I’m also having the same issue. At first I’ve seen that it’s something to do with T-Mobile upgrading their towers but I’m not 100% about it.  If anyone knows anything more about this issue please let me know.

Userlevel 1

I had one rep tell me it was the T-Mobile tower issues. Another rep told me it WASN'T the issue. I've tried several different APN's and most recently I manually changed the Network Operator to T-Mobile to make sure my phone wasn't still trying to connect to AT&T since that is who I got the phone through originally. NOTHING has worked. So another guy from Mint messaged me back on Messenger earlier to get my address so they can send me a new SIM card and see if that fixes it. If it doesn't, bye bye Mint. There's nothing else I can do at that point.

I regret to be the bearer of sad news, but Mint Mobile support is absolutely worthless.  I will take the word of a community forum member before I believe anything Mint Mobile Support tells me. They were absolutely clueless and basically did not even want to put forth any effort to help me what my data configuration. But thanks to the community members and my own research I have resolved the issue myself.  I will not be re-newing with Mint once I am up for renewal.  I understand that Mint is not suppose to be able to give  you tier 1 support like  you would expect if you were a customer of ATT, T-Moble, etc, but when you do get a human talking to you, they should know what they are talking about. 

Userlevel 1

Couldn't agree more! I've dealt with multiple different customer service representatives online and over the phone and never get the same answer for the same problems. The guy I chatted with most recently is gonna send me a new SIM card in case mine is bad. Hopefully that's been the problem the whole time cause if this don't work, I am gone!

Anyone have any success here?  we have 3 phones with mint and 2 out of 3 the data doens’t work after trying to switch from WIFI.  I already bought new sims a month ago with no success.

Same for a Galaxy S7 Active. Data will work for the day after restarting a few times or switching between APN settings. I’ve had to repeat this process every day since the last week of December. Chat with Customer Service Rep basically only had me restart my phone, and I’ve received no response after emailing Mint Support. Not sure if there’s a solution for this at the moment.

You would think Mint would monitor this type of issue and provide support on the message board considering this was posted 13 days ago.  Same issues with on and off data on a Pixel 2 XL.  APN updated and sometimes works, sometime the dreaded x with no data.  Can make and receive calls fine and texts.  Tried to chat support and just got a message that someone would be in contact ‘soon’.  

I believe it has to do with it changing the APN in use after leaving wifi.  Deleting the tmobile one doesn’t help, ill test a few configs.

I wanted to chime in here. Same with my Galaxy S9.

 

I don’t seem to have an issue when entering and leaving wifi; but for me the issue seems to be more reception based. Where i work the building block the signal in some areas, and when i re-enter a good area i have no data - even though i’m showing full LTE. Toggling airplane mode and APNs makes no change. Usually resetting the phone works, but sometimes it needs more than 1

 

My wife has the same phone and has noted some issues similar too, but i haven’t been able to play with hers as much. Tried calling the support line but it doesn’t ring, immediate disconnect. Sent an email this morning but based on reading through the forum i don’ think i’ll get a reply. 

reading other posts i almost wonder if this is just normal…. If T-mobile had to choose between it’s users and us, i’m sure they’d throttle/drop our connection first

I have 2 Samsung S7 phones that I switched to Mint about 1 month ago from AT&T.  The phones are AT&T branded.  I’m having the same problem with inconsistent data connectivity.  I can usually get a signal again through messing with the APN settings or rebooting the phone, but its 5-10 minutes of hassle.  The second chat agent I talked to told my “phone wasn’t fully compatible with their network” even though their online compatibility check prior to purchase said I was good to go.  I’m angry and have already filed a complaint with my attorney general.  He said I should file a complaint with the FCC.  Basically I claimed false advertising.  I’d suggest you all do the same.  

I had been an ultra mobile customer for several years without any problems and just switched to mint 14 days ago. Yesterday, I had problems with sms/mms and data. Phone reboot did not help. I found that, when I switch "preferred connection" from LTE to 2g, it's like I am logged back into data, and afterwards, I can choose LTE again and have a stable connection. Ugly solution, yes, but it works for me. Still, if ultra/mint mobile does not fix the general problem, they have lost this long-year customer to the competition. Cute fox stuff is just stupid if it doesn't work.

Edit: Moto g5+ bought unlocked 

Got a reply back from the customer service emailer. Gonna try some things and update later

Essentially they had me do a network reset on the phone, and told me to set up a t-mobile APN and try that. After the network reset, the Ultra APN that the online tutorial has us fill out was gone, but the t-mobile one was still there.

 

If this works, then my issue was likely my phone trying to toggle between the two APNs causing issues.; Usually i’d experience this at least once a day, so i should have some follow up data tomorrow

Happened again, but the 2G fix from LouKY brought it back. I’ve let customer service know and we’ll see what they say

Userlevel 2

Happened again, but the 2G fix from LouKY brought it back. I’ve let customer service know and we’ll see what they say

Replying to follow. Unlocked Moto Z3 here. Toggling to 2G→ LTE is a work around at the moment. Shame that I bought 3 months and I’m just now learning about this issue. 

An update on my complaint to my state attorney general.  He sent a letter to Mint and asked for a written response within 10 days.  Mint responded that they had looked into my issue, determined it was accurate and refunded my entire purchase but left my service contract in place.  That gives me time to port to another carrier before my contract with mint is up without paying for mint service I won’t use.  It’s unfortunate I had to go to those lengths to get results, but happy with the outcome in the end.  

Chiming back in. They came back with the T-mobile outages response like others have gotten about 10 days ago and nothing since. I’m not dropping service though as the money this plan is saving me is worth toggling to 2G and back 1-3 times a day

 

Would still be nice if this was resolved though. I have some friends on Mint with none of these issues. 

Userlevel 2

I have finally gotten a response from support after 3 days via email asking for my device IMEI, bars of service, and home address (even though it's kn my account…).  Along with this information, I sent this:

  I just want you to understand what is happening when this issue occurs.   After extended use of wifi at home or at work, when I go out of range and it disconnects, LTE appears on my phone with an X indicating there is data service available but my phone is not authorized to use it. There are two fixes, completely rebooting my phone or toggling to 3G and back to LTE 2-3 times to get it to allow my phone access to the data I paid for. I have reset and triple checked APN settings as well as tried other variations of APN that worked for other uses or Mint mobile to no avail. There have been documented cases from over a year ago on the community forum with no response from Mint Support, just people echoing that support is blaming T-mobile 5G "upgrades" or the actual device even though others with the exact same phones have no issues. (also the website specifically said my phone is "perfect" for Mint Mobile service) 

There needs to be a thorough investigation and statement from Mint Mobile because letting an issue fester for almost a year is completely unacceptable and unfair to new customers like myself.

Potentially final update.

 

Still haven’t heard back from support since they blamed T-mobile, but i haven’t had an issue all week. Looks like w.e. it was is now fixed for me

Reply