Solved

MMS not working


Just received my Mint SIM and setup the MMS according to the instructions on the website. On an Android device, I can't send MMS using the Messages app. Doesn't work on WiFi either. Seems to be working through Hangouts. Any ideas?
icon

Best answer by cowbell 29 October 2018, 13:50

I texted SETUP to 6700 and immediately received a reply. Text led me to the websitehttps://www.mintmobile.com/faq/?utm_source=system-msg&utm_medium=sms&utm_campaign=6700-response

Click the appropriate setup for Android or iPhone for MMS and data. I have an android. Here is message 1 of 2 for iPhones.

If you are using an older model iPhone incapable of running iOS 12.0 or higher, you will need to enter your data settings manually.

Setting Up Your Data for iPhone

  1. Select the Settings icon on your homescreen.
  2. Select the Cellular menu option in the first section of the menu.
  3. Ensure that the Cellular Data and Enable LTE are both enabled.
  4. Select the Cellular Data option and enter the following information into the fields:
Cellular Data
APN – alpha
Username – (leave blank)
Password – (leave blank)
MMSAPN – wholesale
Username – (leave blank)
Password – (leave blank)
MMSC – http://wholesale.mmsmvno.com/mms/wapencMMS
Proxy – (leave blank)
MMS Max Message Size – 1048576
MMS UA Prof URL – http://www.apple.com/mms/uaprof.rdf

Restart your iPhone.
View original

14 replies

Just want to relay what worked for me. I tried all this stuff and still didn't work for sending MMS or group SMS (which is as MMS from my Android phone).

https://www.makeuseof.com/tag/what-are-apn-settings-and-how-can-they-fix-data-issues-on-your-prepaid-phone/

  1. APN type: There are four APN types — generic, supl, mms and wap. These vary from carrier to carrier. If you experience issues with official setup instructions, “generic” is always a good default setting.
So I changed the official instruction recommendation of APN type: 'default,supl,mms' to 'generic' - saved - restarted my phone - and it works!
I set up the MMS setting as per the directions. Not really rocket science. The problem is that I cannot delete my previous APN, which is T-mobile (epc.tmobile.com). I saved the Mint APN, ULTRA (Wholesale) and I rebooted my phone. The problem is that upon reboot it always goes back to T-mobile.
It is like T-mobile is my default and the phone reverts back to it every time it is rebooted.
The phone is an unlocked AT&T Galaxy S3.
I am not having any problem receiving Mint calls or Texts and can use all of my APPS as designed. Not really to concerned about this since the phone seems to be working fine. Perhaps if I leave this metro area, the phone will change to the Mint Ultra.
I texted SETUP to 6700 and immediately received a reply. Text led me to the websitehttps://www.mintmobile.com/faq/?utm_source=system-msg&utm_medium=sms&utm_campaign=6700-response

Click the appropriate setup for Android or iPhone for MMS and data. I have an android. Here is message 2 of 2 for iPhones.


If you are using a newer device running iOS 12.0 or higher, your data and MMS settings will be automatically updated as long as you have updated your carrier settings.

To ensure your carrier settings are up to date, go to Settings > General > About > Carrier.
If prompted to update your carrier settings, select Update.
I texted SETUP to 6700 and immediately received a reply. Text led me to the websitehttps://www.mintmobile.com/faq/?utm_source=system-msg&utm_medium=sms&utm_campaign=6700-response

Click the appropriate setup for Android or iPhone for MMS and data. I have an android. Here is message 1 of 2 for iPhones.

If you are using an older model iPhone incapable of running iOS 12.0 or higher, you will need to enter your data settings manually.

Setting Up Your Data for iPhone

  1. Select the Settings icon on your homescreen.
  2. Select the Cellular menu option in the first section of the menu.
  3. Ensure that the Cellular Data and Enable LTE are both enabled.
  4. Select the Cellular Data option and enter the following information into the fields:
Cellular Data
APN – alpha
Username – (leave blank)
Password – (leave blank)
MMSAPN – wholesale
Username – (leave blank)
Password – (leave blank)
MMSC – http://wholesale.mmsmvno.com/mms/wapencMMS
Proxy – (leave blank)
MMS Max Message Size – 1048576
MMS UA Prof URL – http://www.apple.com/mms/uaprof.rdf

Restart your iPhone.
I texted SETUP to 6700 and immediately received a reply. Text led me to the website https://www.mintmobile.com/faq/?utm_source=system-msg&utm_medium=sms&utm_campaign=6700-response

Click the appropriate setup for Android or iPhone for MMS and data. I have an android. I followed the instructions and I appear to be receiving messages now.

Setting Up Your Data for Android
  1. Select Settings. (located within Apps or the pull-down notifications tray)
  2. Scroll down to the Network Connections menu section.
  3. Select the More Networks icon.
  4. Ensure that the Mobile Data is enabled.
  5. Select the Access Point Names or APN menu option.
  6. Select the “+” plus sign to add a new Access Point Name.
  7. Enter the following information into the fields:
  8. Cellular
DataName – Ultra
APN – Wholesale
Proxy – (leave blank)
Port – 8080
Username & Password – (leave blank)
Server – (leave blank)
MMSMMSC – http://wholesale.mmsmvno.com/mms/wapencMMS
Proxy – (leave blank)
MMS Port – (leave blank)
MCC – 310
MNC – 260
Authentication Type – (leave blank)
APN Type – default,supl,mms

Select Save and return to Access Point Names.
Ensure that the new Access Point Name option that you created is selected.
Restart your Android phone.

See next message for iPhone instructions.
Userlevel 3
I have noticed that the MMS instructions that Mint provides when you text to 6700 are somewhat different than the instructions provided on Mint's own website. The instructions are also not as clear as they should be. I really wish Mint would hire a UX/UI person to review its website.
I reverted back to my old setting that I was using before switching to the ones on the MINT website and now I am able to send group messages and MMS is working. Be wary of the MINT suggestions, YMMV. Fyi, this was on a ZTE Axon 7 Android 7.1.1

Multiple attempts to receive the SETUP text message instructions but I never received anything. So far my experience with MINT has been pretty disappointing.
APNs as download to my Moto E4 by using the SETUP command.

That has all the settings I needed to get working (I added them manually which is simple enough), although I found I had to reboot my phone before it would display 4G (or 4G/LTE) in the top bar (indicating I now had data/MMS).
Something people need to remember is SMS is a direct "text only" connection through the towers (text aka words only, not images nor MMS message), versus MMS relies on the data channels, so the APN information needs to be entered properly before data and MMS will work.

I am testing a ZTE Blade V8Pro and a Moto E4 so I am swapping back and forth, although the Moto is still usable on my other company (PagePlus) that uses Verizon towers as my primary.
Userlevel 3
I was having the same issue - could sent texts but not MMS, and then I could receive but not send MMS.

I would suggest looking at the settings not only of your APN, but also within your texting app as well. I use YAATA, and there are several settings in the app itself that needed to be adjusted in order for MMS to work properly.
Thanks for the info. I'll keep trying the SETUP option and the other T-Mobile APN. Will report back.
APNs as download to my Moto E4 by using the SETUP command.
Keep trying the SETUP option. I had to try over several days and it finally downloaded some APN'S for Mint and Mint MMS. And I had to send it about 20 times.

If it is still on your phone, try selecting the T-Mobile APN in the meantime. It worked for me.

I'm also posting the two APN that were downloaded using the SETUP option. You can try manually entering them but I can't promise anything.

Good luck.
I can send SMS no problem, only issues with MMS. Previously using Ting and had no issues on fast.t-mobile.com APN before switching to Wholesale.

Does not work on WiFi. I texted SETUP to 6700 and received a message saying I would be receiving a notification to update my data setting but never received anything.
Can you send SMS?

Check your APN settings. Try texting SETUP to 6700 and let MintSIM download the APN stuff for you. Does it work when not on WiFi? I've read that even using WiFi calling, a cell signal has to be present to send MMS.

Reply