Solved

New customer - OnePlus 6, MMS not downloading

  • 15 April 2019
  • 2 replies
  • 2057 views

I just switched to Mint Mobile from T-Mobile here in the US a few days ago. Since switching, I have not been able to receive MMS messages (which is how group messages are sent/received on Android) at all. I have tried the T-Mobile APN (fast.t-mobile.com) as well as the Mint APN (Wholesale), and every variation of them. I even have a friend on Mint, with his OnePlus 6t, I matched his settings exactly, and I still cannot receive MMS messages (though those settings work for him). I restarted my phone between every APN change, and tried both the stock messaging app as well as the Google messages app - still nothing. I have tried with WiFi Calling on and off, as well as WiFi on and off, but the MMS messages still fail to download. I did send an e-mail to support, which generated a ticket (#3875309), but have not yet heard back from anyone at Mint.

Let me know what else I can try to get my MMS messages working, or what settings/tricks worked for your Android phone?

Thanks
icon

Best answer by Varking 22 April 2019, 16:36

Surprisingly, after one email exchange with support this worked for me.
  1. Tap "Settings"
  2. Tap "Wireless and Networks ( Usually under more options ). For me this was the "Wi-Fi & Internet" tab.
  3. Tap Data Connections / Mobile Data / Use Packet Data, Turn Off Data. For me this was pressing "Sim & Network Settings" and then sliding the "Mobile Data" bar to the off position.
  4. Tap Access Point Names. For me this was tapping "SIM 1 ( Mint) and then scrolling down and tapping Access Point Names.
  5. Delete all existing APNs if possible. For me only the one that I added from the site could be deleted. There were three I could not touch.
  6. Press "Menu" and tap "New APN". For me I had to hit the "+" and then start adding in the information below:
  • Name: T-Mobile US LTE
  • APN: fast.t-mobile.com
  • Proxy: Leave this blank
  • Port: Leave this blank
  • Username and password: Leave these blank
  • Server: Leave this blank
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapanc
  • MMS Port: 8080
  • MCC: 310
  • MNC: 260
  • Authentication Type: Leave this blank
  • APN Type: default,supl,mms

After this you just need to save the new APN. Turn Wifi off and keep data off. Reboot your phone and turn both back on and make sure you enable this new APN again because sometimes after reboots it defaults back to the main one. About an hour after I had these new settings I can send and receive MMS while on Wifi. Sending seems quicker than receiving them but at least them come through now. Hopefully this works for you.
View original

2 replies

Userlevel 2
Waiting for this information as well. I can send MMS messages like pictures if I turn the wifi off. It seems while I am on Wifi I can't send or receive MMS. I got everything else working on my OnePlus 6 like Wifi Calling and SMS works but the MMS hasn't been acting right just yet. I am determined to find a fix!
Userlevel 2
Surprisingly, after one email exchange with support this worked for me.
  1. Tap "Settings"
  2. Tap "Wireless and Networks ( Usually under more options ). For me this was the "Wi-Fi & Internet" tab.
  3. Tap Data Connections / Mobile Data / Use Packet Data, Turn Off Data. For me this was pressing "Sim & Network Settings" and then sliding the "Mobile Data" bar to the off position.
  4. Tap Access Point Names. For me this was tapping "SIM 1 ( Mint) and then scrolling down and tapping Access Point Names.
  5. Delete all existing APNs if possible. For me only the one that I added from the site could be deleted. There were three I could not touch.
  6. Press "Menu" and tap "New APN". For me I had to hit the "+" and then start adding in the information below:
  • Name: T-Mobile US LTE
  • APN: fast.t-mobile.com
  • Proxy: Leave this blank
  • Port: Leave this blank
  • Username and password: Leave these blank
  • Server: Leave this blank
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapanc
  • MMS Port: 8080
  • MCC: 310
  • MNC: 260
  • Authentication Type: Leave this blank
  • APN Type: default,supl,mms

After this you just need to save the new APN. Turn Wifi off and keep data off. Reboot your phone and turn both back on and make sure you enable this new APN again because sometimes after reboots it defaults back to the main one. About an hour after I had these new settings I can send and receive MMS while on Wifi. Sending seems quicker than receiving them but at least them come through now. Hopefully this works for you.

Reply