Solved

iMessage Not Showing Phone Number

  • 15 February 2020
  • 1 reply
  • 16 views

Hi All,
I just swapped to Mint from Verizon, and my iMessages are showing up oddly now. Instead of showing as coming from my phone number, I am being told it comes from my email address instead. Is there a way to fix it so that it does come from my phone number?

Thank you!

icon

Best answer by Rain_Vydan 15 February 2020, 01:28

Managed to find it by playing around with settings. In the iPhone Messages settings, under iMessage, you can choose your Send&Receive and make it your phone number. Hope this helps someone else out there!

View original

1 reply

Managed to find it by playing around with settings. In the iPhone Messages settings, under iMessage, you can choose your Send&Receive and make it your phone number. Hope this helps someone else out there!

Reply