Solved

Why do I not have voicemail notification ?



Show first post

38 replies

Last night it all worked; I hope it stands the test of time......
Also a new Mint customer that joined in January 2018 with a new Moto G5 Plus. Noticed problems with no incoming calls, no missed call notification, no voicemail notification, and delayed incoming SMS/MMS delivery.

I made a change that seems to have helped. Under settings > Wireless & Networks > More > Cellular Networks > Network Operators, I explicitly selected 'Mint' (other options for me included Verizon and AT&T).

Since making that change, I have not noticed any of the above issues. I do still check my VM manually from time to time to make sure. I also call my cell phone from Gmail/Hangouts Dialer every once in a while to make sure my phone rings.

Maybe this will help others with the same issue 🤞
Userlevel 1
I have the exact same issue. Using OpnePlus 2, which is unlocked and supports all major T Mobile bands.

I have tons of dropped calls, no missed called notifications, delayed Voice mails and poor consistency with data speeds.

if someone calls me, it rings twice or often goes to voicemail. If the caller does not leave voice mail, I never know about the call. This is ridiculous. I have browsed this forum and see the same issue with many customers.
Will be porting out soon, dont think Mint will be able to sort it out, like ever, else they would have done it.
Same thing happening here. Switched from ATT.
Showing no missed calls and no voicemail notifications, but called in to discover 9 voicemails from the last 7 days. HTC One A9 is my phone model.
I had this issue on my iPhone 8 plus. It presented itself in two ways. I would not receive voicemail notifications when I had a voicemail, and then at times I would receive a bunch of random voicemail notifications on my lock screen when i did not have any voicemails in my inbox. I had this issue for many months but just recently found a solution that worked for me and it may work for you too. It had to do with what LTE was enabled for. If you go into settings under SETTINGS>CELLULAR>CELLULAR DATA OPTIONS>ENABLE LTE>DATA ONLY. Chances are that your phone is currently set to "Voice & Data", this is what seemed to be the issue. Change it to "Data Only" and any ghost notifications should go away after turning the phone off and back on. Then you should also receive notifications for when a voicemail is left in your inbox. Hope this can help.
Same exact issues as everyone else. I am using a ZTE Axon 7. I used this phone with Ting (also a TMO mvno) before coming to Mint. No issues ever. For me this issue with Mint has only started in the past week. And only during peak usage hours between 4 pm and 9 pm. But it's annoying enough that I will port out as soon as I am up for renewal. For now I am lucky to have wifi calling on my phone and it works.
theSheepdog_X8 wrote:

I had this issue on my iPhone 8 plus. It presented itself in two ways. I would not receive voicemail notifications when I had a voicemail, and then at times I would receive a bunch of random voicemail notifications on my lock screen when i did not have any voicemails in my inbox. I had this issue for many months but just recently found a solution that worked for me and it may work for you too. It had to do with what LTE was enabled for. If you go into settings under SETTINGS>CELLULAR>CELLULAR DATA OPTIONS>ENABLE LTE>DATA ONLY. Chances are that your phone is currently set to "Voice & Data", this is what seemed to be the issue. Change it to "Data Only" and any ghost notifications should go away after turning the phone off and back on. Then you should also receive notifications for when a voicemail is left in your inbox. Hope this can help.



This worked, thank you! Was not receiving voicemail notifications (yet receiving random ones when no voicemail was there), and after changing this setting, I tested and got a notification immediately after leaving a message. Does make me wonder what I've disabled by disabling "Voice"?
@theSheepdog_X8
Well, just read up on what turning off the Voice & Data option does, and it eliminates the ability to both talk and access web/apps/imessage...data...while on a call. The calls, rather than going over 4G LTE switch to a 3G antenna. So, in order to solve our "don't get any voicemail notifications" issue with this method, we now have another problem. C'mon Mint, what's our solution here?
Same problem here on my OnePlus One...

I just rejected a call, and they left a message. Went to see what message they left, and I had five new voicemails from the last week waiting!!

My contractor, my parents, and other calls I wish I had gotten.

What is going on?!
theSheepdog_X8 wrote:

I had this issue on my iPhone 8 plus. It presented itself in two ways. I would not receive voicemail notifications when I had a voicemail, and then at times I would receive a bunch of random voicemail notifications on my lock screen when i did not have any voicemails in my inbox. I had this issue for many months but just recently found a solution that worked for me and it may work for you too. It had to do with what LTE was enabled for. If you go into settings under SETTINGS>CELLULAR>CELLULAR DATA OPTIONS>ENABLE LTE>DATA ONLY. Chances are that your phone is currently set to "Voice & Data", this is what seemed to be the issue. Change it to "Data Only" and any ghost notifications should go away after turning the phone off and back on. Then you should also receive notifications for when a voicemail is left in your inbox. Hope this can help.



I used this solution, too, after calling in and working with someone who was clearly clueless about this issue even though he said he had gotten several calls about it.🌵

So far this is working ok, but I've gotta say- this is really poor for any amount of money, $15/month or even lower. Seems like they have known about this issue for 4 months and haven't identified a proper solution. They are heavy on advertising (which basically consists of an aloof green fox), poor on customer service and issue resolution.💩

If this isn't properly resolved within the next month, I'm not going to renew my contract. 🤢

Clearly, this is a known serious issue, occurs with multiple phone models, and goes to the core of precisely what customers are paying for and precisely what Mint is contractually bound to provide its paying customers: cellular telephone service with phone calls, text messaging...



CLASS ACTION LAWSUIT, ANYONE???

I am SO frustrated with this! Both my husband and I switched to Mintsim and neither one of us receives voicemail notifications. I don't like the 3rd party apps as they conflict with my other apps. Purchased my S8+ from Sprint and it will not work on other contract free providers (grrrr, told it would). So, I can't change now other than to $$$$ Verizon or Sprint.

Here is what I received from customer service last month:

Edgar Ciprian Castillo Batista (Mint Mobile)
Jul 13, 12:03 PDT

Thank you very much for getting back to us and the information provided.

In regard to the voicemail notification, you can dial #796# to reset your voicemail but please be advised that at the moment we don't any feature that allows you to get voicemail notification because unfortunately, we don't have a specific app that you can download but we have heard from our customers what you could do is to download a voicemail app from your google play store or app store, one that most fit your needs and it might solve the issue for you voicemail notification but there is no guarantee until get it available because the technical department still making updates and as soon as we get it available we will let you know.

If you have any further question please don't hesitate to reply or contact our Customer Care Line at 800-683-7392 / dial 611 from your device.

Thank you for contacting Customer Care Support.

Best Regards,
Edgar
Need a quick answer? Check out our FAQ’s or try our chat bot on www.mintmobile.com
-Kindly be informed this ticket will be closed after 48 hours of no response by the customer-

Reply