Question

Wi-Fi calling setting is missing on my phone previous carrier disabled it

  • 9 October 2018
  • 3 replies
  • 424 views

  • Anonymous
  • 0 replies
I have a Samsung Galaxy S8 that is compatible with wi-fi calling however I recently tried Twigby before going with mint. The sim card that I got from Twigby disabled all wi-fi calling as that wasn't available with them. Now that I have the Mint Sim in my phone and everything works except wi-fi calling. The first 8 of the IMEI number are even on the compatibility list. The setting for Wi-Fi calling is gone and I am trying to get it back without doing a factory reset

3 replies

Hi - I have the same issue, did you get a resolution for this?
Have you checked if Wi-Fi calling setting was available in Phone app rather than Android Settings app? Launch your default Android Phone app, click on three vertical dots in the upper right corner and go to Settings. Then, go to Calls and click on Wi-Fi calling. Hope it helps.
Thanks for responding. So it is getting disabled by mint, it seems to be a setting in the Sim card. Although I thought my unlocked S8 phone is supported, the first 8 digits of the imei number 35833208 is not in the mint Wi-Fi calling supported devices list. Their pathetic support team do not even know the existence of the first 8 IMEI letter supported devices page. https://www.mintmobile.com/wifi-calling-text/

I switched the phone to a MetroPCS Sim and immediately the option came back. When I put mint Sim again, it went away. So it's not a tucked away setting or my phone, it's mint that disabling it.

Hope this post helps others.

Reply