Question

WiFi Calling option not there on Samsung Galaxy S8


I have Samsung Galaxy S8 and my IMEI starts with 35598208 so my phone is definitely on the Wifi Calling and Text supported devices list.
https://www.mintmobile.com/wifi-talk-text/

But I don't see that option anywhere on my phone.

It was bought new from Amazon, unlocked.

Everything works on the Mint network but I can't turn this feature on.

I have enabled it on the website, I got a confirmation SMS that Wifi Calling and Text is turtned on for my account. I can see it turned on when I log on the web.

But I don't have that option anywhere.

I have checked under settings, Connections, More Connection Settings -- not there!

I have also checked under the Dialer, three dots, Call Settings -- not there either.

Help me please. Any other method to put that option in the menus so I can turn Wifi Calling on?

4 replies

I have Samsung Galaxy S8 and my IMEI starts with 35598208 so my phone is definitely on the Wifi Calling and Text supported devices list.
https://www.mintmobile.com/wifi-talk-text/

But I don't see that option anywhere on my phone.

It was bought new from Amazon, unlocked.

Everything works on the Mint network but I can't turn this feature on.

I have enabled it on the website, I got a confirmation SMS that Wifi Calling and Text is turtned on for my account. I can see it turned on when I log on the web.

But I don't have that option anywhere.

I have checked under settings, Connections, More Connection Settings -- not there!

I have also checked under the Dialer, three dots, Call Settings -- not there either.

Help me please. Any other method to put that option in the menus so I can turn Wifi Calling on?


Hello, can you direct message me your mobile number? I'll further research your account, thanks.

-Natalie
Mint Mobile
Userlevel 1
Natalie can you provide any information to Samsung S8 owners whose IMEI number is NOT on the list as to why WiFi Calling & Text is not supported, and if it will be at a future date. It is just surprising to me that a 1 year old flagship phone with such advanced technology would not be able to use this service. (although it was purchased from Best Buy for Verizon - CDMA)
As a note, I activated WiFi Calling & Text although my IMEI number was not listed and got a text from Mint saying
"Success! WiFi calling is officially activated on your Mint phone!"
Why would this happen when it is NOT working on my phone?
I solved my problem regarding NO WIFI CALLING on my Samsung S8.

I could never find the Wi-Fi Calling setting - it was not under SETTINGS > CONNECTIONS > MORE..

After the last Samsung software update (few days ago) my Wifi Calling stopped again. So after searching the web - I found a thread that said the setting has moved

It is now under call settings. Go to the phone icon / dial pad, hit the three dots in the corner > settings > wifi calling.

So to restate. Press the phone app (assuming it has to be the default Samsung). On any page that's up (recent, dialpad, etc) there will be three dots at the top right. Press the three dots and the pop-up menu will have settings as a choice. Press that. And it's right there.

Mine was OFF. I turned it on - and now have Wifi Calling.
I am having the same problem with my Galaxy S8.

I checked the list and my IMEI number matches the ones where it is listed as an option but I can't find the setting anywhere in order to turn it on (it wasn't in either of the two locations: I checked under settings, Connections, More Connection Settings and it's not there! I have also checked under the Dialer, three dots, Call Settings and it's not there either).

@SMS_Dad, were they able to fix this? If so, how?

Reply