Solved

Could not activate cellular data network


So I've been having this issue sporadically for months now, ever since I switched from an iPhone 7, to the iPhone X. At first I thought it was a phone issue since the problem usually happens when I'm on either my home or work wifi, and then leave - at which point the cellular data wouldn't function until a reboot the phone.

I've since done everything I can with my phone, wiped all the saved wifi networks, wiped the phone and installed fresh, etc. So now I'm turning to the problem being with Mint Mobile.

Has anyone else ever had this problem, or have thoughts on solving it?
icon

Best answer by bcoyle 2 August 2018, 14:02

@startech this solved my issues, https://www.reddit.com/r/mintmobile/comments/8phwn9/iphone_x_loses_wireless_data_within_24_hours/

it has almost been a week without a single issue. probably not the most official way to fix it, but works until Mint Mobile gives us better details to enter into the cellular settings.
View original

21 replies

Userlevel 4
Badge
So I've been having this issue sporadically for months now, ever since I switched from an iPhone 7, to the iPhone X. At first I thought it was a phone issue since the problem usually happens when I'm on either my home or work wifi, and then leave - at which point the cellular data wouldn't function until a reboot the phone.

I've since done everything I can with my phone, wiped all the saved wifi networks, wiped the phone and installed fresh, etc. So now I'm turning to the problem being with Mint Mobile.

Has anyone else ever had this problem, or have thoughts on solving it?


Sorry to hear of the inconvenience. We'll reach out to you for more account specifics.
Hi Royce,

I have emailed support and only gotten a generic response about settings to input into the cellular data network options.

Problem is hard to pin down because it doesn't happen all the time. But it always happens when leaving a wifi connection and switching to cellular data.
I've had this problem as well on iPhone 7. It seems to occur when I go into a low signal area, like a parking garage then exit. Cellular won't work again until I reboot. Very frustrating.
@startech I still haven't ruled out Mint SIM, I have privately given them more info and haven't been able to find the issue. Apple even swapped my phone out and the issue persisted. Your low signal area is an interesting point, because the places I go for wifi (work and home) also have low signal - with home being worse than at work.

I have found that even when the cellular stops working, I am able to receive phone calls. SMS doesn't work until reboot.

It's odd that you're having this problem on an iPhone 7, before I upgraded I was on an iPhone 7 and didn't have this issue until upgrading hardware. Maybe there's a conflict between the latest iOS software and Mint SIM.

@Starfox when you're in this parking garage with low signal, are you on any wifi network? Or do lose cellular data at any point that the signal dips low enough and never recovers later?
@bcoyle pretty sure I wouldn't be on wifi at that point but haven't checked explicitly, will take note next time. Pretty sure it's just when it dips low enough and never recovers. Do you remember if you were running the same iOS version on your iPhone 7 when you got your iPhone X?
@startech I must have, at least for a few weeks before the X dropped. And my problems started that first month of owning the X. I always jump on those latest iOS updates... but maybe it wasn't enough time for me to trigger the cellular drop. I can go days without it happening. And then one a weekend when I'm home, in and out of the apartment - I can have it seize up multiple times.

Maybe I'll try disabling Wifi one weekend for a couple days to see if I can cause the cellular issue. Just annoying to blow through the data at home to test... that would rule out my whole theory of it being an issue when switching between wifi/cellular.
@startech just ordered a faraday pouch to see if I can simulate the signal dropping to trigger the cell data issue. If so, I can take to the Apple Store and reproduce.
Good idea! Interested to see what you find out.
@startech Now that I think about it - my signal drops over and over when I ride the NYC subway. Between stations there's no service. But I've never had cellular data issues from that.
Hmm, interesting. I have a similar experience when I drive through the country and there's no service. It'll reconnect fine when there's a signal. So maybe there's a narrow range where it manifests (low signal vs no signal).

Did you have T-Mobile before? I did and never had this problem but it wasn't while I used this parking garage I have so much trouble with. But I think you may be onto something about it being a wi-fi/cellular interaction. Kind of a shot in the dark but I'm going to try turning off wi-fi assist. I've just left town so won't be able to try for a while.
@startech phone was fine yesterday - I had wifi turned on. Came home and used wifi all evening and this morning. Turned off wifi and cellular data was gone. Rebooted. Going to keep wifi off today as I'll be in and out of my basement where the cell service is bad, see if the issue appears. I'd think if this was a Mint SIM issue, more Mint SIM iPhone users would be on the forums complaining. Maybe my sim card is just defective.. but odd that phone service still works, while data doesn't.

edit: I've also noticed that GPS is failing when I'm at my two wifi locations (with wifi turned OFF). Not sure if that means anything, or is just another side effect of being in a low cellular signal area.
Same issue here. Apple replaced my iPhone X with no effect. The weird thing is that the phone says the LTE signal is fine, but no data is coming through. I second that it happens when cellular signal is weak, e.g. on the subway, in basements, in my bedroom... The only way to temporarily fix it is rebooting the phone.

I haven't tried other providers, but I'm debating to switch to T-Mobile at least for a month just to see if the issue persists.
@nosignal another case?! This is really strange.

I'm reaching out to Mint Sim to get a replacement sim and see if that resolves it. Otherwise my gut feeling is that there is an issue on Mint Sim's side, something to do with iOS 11 software.

Since @startech is on an iPhone 7, that rules this issue out as being iPhone X only. But possibly a software issue since I had an iPhone 7 previously with Mint Sim and wasn't encountering this issue.

I'm surprised there aren't more iPhone users reporting this issue. That's the only thing that makes me think maybe this is just a bad sim card issue and not every iphone user using mint sim...
@startech this solved my issues, https://www.reddit.com/r/mintmobile/comments/8phwn9/iphone_x_loses_wireless_data_within_24_hours/

it has almost been a week without a single issue. probably not the most official way to fix it, but works until Mint Mobile gives us better details to enter into the cellular settings.
@bcoyle Thank you! Didn't think to check reddit.
I don't seem to have this option (update APN settings) in iOS 12. Anyone else able to do this? I have two phones with this problem.
Have same issue on my new gsm unlocked iPhone 7. Happens switch from WiFi to cell. Sometimes can be fixed by toggling the roaming and lte settings
I am facing exactly same issue on my iPhone 7 too. Only way to fix is to restart iPhone.
I am facing the same issue on all 4 iPhones very frequently. Rebooting the phones fixes the issue. I have called mint customer support many times but no resolution yet. They keep asking me to reset the network settings etc but none of their solution helps. The issue is that when I go out of wifi network to mobile LTE network, it says no network connection. It is very frustrating and I am planning to cancel all the 4 lines and change the provider.
I am facing the same issue on all 4 iPhones very frequently. Rebooting the phones fixes the issue. I have called mint customer support many times but no resolution yet. They keep asking me to reset the network settings etc but none of their solution helps. The issue is that when I go out of wifi network to mobile LTE network, it says no network connection. It is very frustrating and I am planning to cancel all the 4 lines and change the provider.
I have this problem for a while. planning to move out of Mint as soon as my long 12 months ends. I need to reboot my 2 phones almost every day in order to get LTE to work.

I am a new mint customer and I also get no cellular data. I have just purchased an unlocked iPhone 8 with iOS 13.3 installed. I get no data whilst on LTE and it’s persisted now for days. Mint customer service is almost non-existent, and reading forums there does not seem any good solution except to install a different profile for APN, which I am slightly uncomfortable with. The only solution I could find myself was to change to ‘4G’ from the LTE option under Cellular Data Options » Voice & Data, and data started working, but I have no idea if that’s correct. Anyone got any advice?

Update: I did call customer service, just noticed contact number was through the Cellular settings menu on phone. Basically cust service told me to stay with ‘4G’ option. still could not quite understand why default LTE option will not work but data is working again so I'll stick with it. 

Reply