Wi-fi calling still not working

  • 26 June 2018
  • 4 replies

Hello all,

After a month of trial and error, I still don't think my Moto g5+ is connectng via WI-Fi.
Thankfully I don't get many calls, but this has gotten bad for me. I've done a bunch of things
already including taking the SIM card in and out, trying to reset things a little and modifying
some network settings, without breaking anything else in the process. I've seen a fair amount of
others here are having the same trouble, to one degree or another. Time to get this fixed or
I'm shoving off to a different carrier.


4 replies

Userlevel 2
I have a Moto G5+ and have wifi calling working fine from day one. So your phone shouldn't be the problem unless it is defective.

I assume that you have enabled wifi calling in your on line account. Have you tried it in different settings or just at home? If just at home, what internet service and router do you have? If you put your phone in airplane mode and then re-enable wifi, can you call out? Can you send a text? Can you access the internet through the phone's browser? When you go to Settings/Wireless&networks/More, do you see the option to turn on wifi calling? What APN setting are you using?

Answers to these questions may help us help you.

It would be good if there would be an icon in the toolbar that shows you that wifi calling is active.
Ok, it appears I have a number of questions to answer. I'll answer these in order.

First, the Wi-Fi calling option has been enabled on both my account and my phone.

The cell service seems to work fine on the road and I only connect to Wi-Fi at home.

I have AT&T for my ISP and I have one of the newest gateways they provide: Pace 5268AC.

As far as turning Airplane mode on and off, the wi-fi turns back on, no problem.

Texting is a totally different issue. The other night I had to manually reconnect to the cell
network numerous times to carry on a conversation and I was here at home.I should think
texting would be handled by wi-fi, no?

I can't tell if I'm using cell or wi-fi for browsing the net.

Finally, about APN's, I have 4 T-Mobile AP's available. I'm currently on T-Mobile US 260 LTE.

I'm most frustrated by the fact that I can't seem to get off the cell network when I'm at home.
I've never had these problems with other carriers in the past. Let me know what you think.

Thanks for your time,

Userlevel 2
I went back to your first post. There really are two questions. One is whether your phone is connecting to wifi at all. The second question is whether wifi calling is enabled and working.

"I can't tell if I'm using cell or wi-fi for browsing the net." First, to test your wifi connection put the phone in Airplane mode, With the phone in Airplane mode, turn wifi back on. Open your browser and go to a web page of your choice. If you can pull up a web page, that confirms that your phone is connected to wifi and receiving data.

Then, for wifi calling, several things to try. I'll start with APNs.

You should have 4 T-Mobile APNs plus a Mint APN. Mint wants you to set up a custom Mint APN. That can be done by texting "SETUP" to 6700. That doesn't always work. If not, create a new APN manually. Here is a link on how to do it: Android APN Setup for Mint

The odd thing is that after following those directions and restarting my phone, the T-Mobile US 260 LTE is checked, not the new one that Mint had me set up. Despite this, wifi calling still works. So, it seems that simply having created the Mint APN is what's needed.

I have found that I cannot call out with wifi calling while the phone is in airplane mode but can receive calls. So, If you can get someone to call you, you should get a pop-up saying in coming wifi call.

So, try those things and let us know.
Hi pikeviewer2,

Well now I'm positive that the wi-fi on the phone is not working properly. Just about everything is
still being transmitted via cell network. I tried to check voicemail and an error message popped up
saying the cell networks are unavailable and to switch to wi-fi calling. That happens with all the calls I
try to make. I tried setting up a Mint APN and even though it says it's connected, the song remains the
same. The only thing that is working on wi-fi is internet browsing. So, wi-fi calling and texting are the 2
things that aren't working, as far as I can tell.