F.A.Q.

What are and why do you need to set up my APN settings?


Userlevel 3
APN settings allow you to send photos/pictures (MMS settings), and use data. You can update by manually entering the information below. Remember that these reset when you remove your SIM or update your OS.

iPhone



On your iPhone, go to Settings -- Cellular -- Cellular Data Options -- Cellular Data Network (this may differ depending on which iOS version you have)

Now enter the following under each field:

CELLULAR DATA
APN - alpha
Username - (leave blank)
Password - (leave blank)


MMS
APN - wholesale
Username - (leave blank)
Password - (leave blank)
MMSC - http://wholesale.mmsmvno.com/mms/wapenc
MMS Proxy - (leave blank)
MMS Max Message Size - 1048576
MMS UA Prof URL: - http://apple.com/mms/uaprof.rdf

LTE SETUP (OPTIONAL)
Leave all these fields blanks

Android



On your Android device, go to Settings -- More Networks -- Cellular (or Mobile) Networks -- Access Point Names -- hit the '+'

Now enter the following under each field: Cellular Data:
Name - Ultra
APN - Wholesale
Proxy - (leave blank)
Port - 8080
Username & Password - (leave blank)
Server - (leave blank)
MMS: MMSC - http://wholesale.mmsmvno.com/mms/wapenc
MMS Proxy - (leave blank)
MMS Port - (leave blank)
MNC - 260
Authentication Type - (leave blank)
APN Type - default,supl,mms
MCC - 310

11 replies

What is the APN protocol?
IPv4 or both IPv4 and IPv6?
Userlevel 4
Badge
That would depend on the devices capability. Usually we leave it to what the phone is already set to.
I am 0-for-4 with the SETUP to 6700 method -3 devices across two phone numbers (one device had an OS update to Android Oreo, at which point I tried again. The video is useless, as it simply says to use the SETUP to 6700 method. Is there a list of preparatory steps which will increase the likelihood of success?
Userlevel 1
I know of several instances where friends who have switched to Mint Mobile as well as seen in several posts in the forum, that MMS is a problem! Usually the issue for ANDROID is not being able to attach images to text messages. This is caused by a stupid issue, and Mint Mobile should modify their instructions.

When manually entering the APN parameters, there is a parameter - APN Type that should be set to: default,supl,mms. The problem is that most keyboards automatically enter a space after a comma so that the parameter is set to: default, supl, mms See the spaces after the commas? This causes problems. YOU MUST DELETE THE SPACES AFTER THE COMMAS SO THAT THE PARAMETER LOOKS EXACTLY LIKE WHAT IS SHOWN IN THE INSTRUCTIONS!
I have a SSG S5 G900v which is stuck at Android 5.0 (no further updates). I recently switched to Mint and all works except for voicemail (long press on keypad 1 does nothing and gives me an error recording that it can't be dialed. I set the 805 number to voicemail and it still won't dial). Plus on calling a number and getting the "press 1 for tacos, 2 for the kitchen, etc" isn't recognizing my keypad presses. It worked before but doesn't now. I never recvd a txt message that would do whatever for auto setup, though I have seen the send SETUP to 6700. Plus my S5 doesn't display an option for APN, tho my previous S4 did have that APN option displayed. I have already posted and emailed about this but mint hasn't replied yet, and it's been a week
I also had an issue using the Samsung s9. I could not send pictures through text even though I followed the set up instructions for the APN for android. I called MInt and they talked me through a few things however it was escalated to a higher tech support. They will call me Monday. As I was looking through the instructions again I noticed two things, as someone pointed out about the spacing of the commas, that was correct.

You have to manually make sure the words are not spaced (APN Type - default,supl,mms)
I have already "resolved" my problem with the APN. I still have the problem of not have tones so when I get "press 1 for tacos, 2 for the kitchen, etc" my S5 STILL isn't recognizing my keypad presses so I just hang up. Now I've noticed that my S5 displays TMobile though the wife, who also has Mint also (she got it first, I got it afterwards) displays Mint on her Samsung J2.
The Access Point information that was texted to me for set up on 6700 is different than what is above, and I received two different texts back to back. "APN type" says only "mms" on one text and "default" on the other, "default,supl,mms", above, and there is no port entry for the texts which leaves it at "not set", but above says "8080". The name says "Mint" on one, "Mint MMS" on the other and "ultra" above. And the text says visit www.mintmobile.cofaq/ which just gives me an error message each time I try.
Why aren't these consistent? They should be. And why does a customer have to point this out? Mint should definitely be on top this basic necessity. Someone in charge is extremely dropping the ball!
Hey risksuccess: Just reading your post and I agree it is very confusing. It's been a few weeks since I signed up and mine states I am signed up with T-Mobile and never says I am with Mint, and of course my wife - also with Mint - displays Mint on her cell home page. Mine has always displayed T-Mobile and never mint, though I have updated the APN settings. One thing I DID notice about your post was the FAQ link you posted is incorrect. Try this instead: https://www.mintmobile.com/faq

Good luck!!
Thanks for your response.
I cannot download messages or pics, or send or download MMS, group messages do not come through. I cannot update PRL or Profile.

Here is an update:

My S6 phone was previously with CREDO using Sprint lines, my S6 bought from Credo, is an original Sprint phone.
(Side-note: Credo is overpriced and their customer support is none existent when you have any problem. They did not unlock my fully paid phone when I requested this, it took 2 weeks and hours and hours of being on hold numerous times. I waited on hold over 2 hours one day 1:40 another, etc etc with no help).

I continue to have the same problem. Mint has been useless in assisting me, they said call my previous carrier my phone could be partially locked, which reluctantly, I did and they were useless again, denying any cause could possibly be theirs. Since Mint uses T-Mobile lines, I troubleshooted on their site, and decided to try entering a new access point with T-Mobile's APN, (below) and then I turned off the WiFi and I was able to download my messages, but each time I must turn off my WiFi go to settings, mobile networks and turn Mint off and T-mobile on, get it downloaded and then change it back. It's time consuming and frustrating and utterly RIDICULOUS!

I still get this error message: "power off your device insert service provider UICC that came with the device then power on the device", of course this does not work. I cannot update my profile or PRL without getting the same message. I have spent so many frustrating days and hours on this, wasting my time and neither company will resolve this. It's absurd that when I search for resolution of this issue, this it is not isolated, there are so so many from years ago, and mainly with Sprint phones. The problem must lie with Sprint, but someone in the tech world should have been able to resolve this, since Sprint obviously refuses.

My solution is NOT a solution, I have no clue why this would even work, and it is not listed as a solution anywhere.
If anyone has a real solution PLEASE let me know.

I entered the APN data for T-Mobile:
1. Verify and update the following settings for the Data APN.
o Name: T-Mobile
o APN: Fast.t-mobile.com (for LTE devices) or epc.tmobile.com (for non-LTE devices)
o Proxy:
o Port:
o Username:
o Password:
o Server:
o MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
o MMS proxy:
o MMS port:
o MMS protocol: WAP 2.0
o MCC: 310
o MNC: 260
o Authentication Type:
o APN Type: default,mms,fota,hipri,supl,admin,mobile OR Internet+MMS OR o : default,supl,mms OR Internet+MMS
§ Or default,mms,fota,hipri,supl,admin,mobile
§ Default Android provides a text field to enter: default,supl,mms.
§ Samsung provides an Internet+MMS radio button to select.
o APN Protocol: IPv4/IPv6
o APN roaming protocol: IPv4/IPv6 or IPv4 only when roaming internationally
o Turn APN on/off: Grayed out unless there are multiple APNs
o Bearer: Unspecified
2. Press the Menu key.
3. Touch Save.
4. Delete any other APNs that appear in the list. The FOTA APN can remain if available.
5. Verify there is a circle next to the remaining APN.
6. Perform a soft reset. Hold down the power button until the device turns off and restarts.
7. Test the data connection and/or MMS by accessing the Web or sending a picture message.
8. Complete additional troubleshooting if the APN settings are correct, but customers still experience issues.
My phone works fine with the default T-Mobile APN settings, so I've stopped bothering with the MintMobile specific settings.

I use custom ROMs and wipe my phone a lot, it was a pain to reset the APN settings every time, but I found that the defaults seem to work fine for me which shows up as "Mint" under mobile networks, but T-Mobile in the details, and the APN is "T-Mobile US (fast.t-mobile.com)".

I'm using a fully unlocked Google Pixel 2 phone that I got as a refurb for xmas 2018 present to myself.

Reply